1

I'm trying to run a civicrm core module upgrade on a drupal 7 site. I follow all of the posted instructions, but when I run the civicrm/upgrade I get a white screen. When I return to the drupal modules the main civicrm core module is no longer listed. If I run the drupal upgrade script I get an error message that civicrm module is missing ... but I can see the module loaded on the server, with all it's files, in the correct location.

I shouldn't have to uninstall the module because I'm upgrading. I disabled all of the civi helper modules, but made sure to leave the main civicrm module enabled, but I still get the missing module message.

Any help would be greatly appreciated.

  • 1
    any chance you left the old civi code around in a re-labelled folder? – petednz - fuzion Apr 2 at 20:21
1

Since it's no longer listed and it says it can't be found, it's usually one of these two things:

  • your files are uploaded into the wrong spot
  • your files have the wrong permissions and/or user attached
  • I've double checked that as well. According to documentation provided on CiviCRM + Drupal 7 upgrade, I downloaded the new civicrm files, disabled the all civicrm related contrib modules (but left the main civicrm module enabled), deleted from sites/all/modules the older civicrm directory, copied the new civicrm directory into the new location, cleared cache and template items cache, and then run the upgrade for civicrm/upgrade .Once I run the upgrade nothing happens, but the page goes white and civicrm is no longer an option on my site admin menu and the module is no longer listed. – Brett Apr 3 at 15:07
  • That's what makes it sound like it is a location, permission, or user attached issue - it's either not finding the files or is unable to access them based on your description. – Jenni Simonis Apr 3 at 17:14
  • 2
    Jenni is right - this sounds like a user permission issue. Is it possible the files are owned by a different user than they were previously? – Jon G - Megaphone Tech Apr 4 at 3:00
  • OK - I'll give it another go and see what I can find. Thank you for your help. As an added note, I did revert back to the original civicrm files and everything came back just fine. Same exact file location and permissions as I had for the newer files. – Brett Apr 4 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.