2

When i set up the Settings this way: http://example.com/civicrm/admin/setting/url?reset=1

[cms.root]/libraries/civicrm

It tries to resolve resources from:

http://default/...

When i change to absolute path:

http://example.com/libraries/civicrm

it works. But should't the example above be correct?

SOLVED Edit:

as @Demerit and @Aidan corectly pointed out, that setting was in

civicrm.settings.php 

in

web/sites/default/

TY!

  • 2
    Which CMS are you using? On the Resource URL's settings page, click the help icon and check the values displayed there. Check your civicrm.settings.php and see what URL's are set there. – Aidan Apr 3 at 9:19
1

This may not be relevant, as the URLs don't look like Wordpress, but I had a similar problem when I had a dev version on dev.example.com. The absolute path is

https://dev.example.com/wp-content/plugins/civicrm/civicrm/

But [civicrm.root] is

https://dev.example.com/dev/wp-content/plugins/civicrm/civicrm/

The problem is that the files are held in subdirectory dev but this is handled by a redirect in the CMS hosting service.

There was no problem when the URL was just example.com. So also depends on the actual URL you use for CiviCRM.

1

I think I'd agree with @Aidan it's probably in civicrm.settings.php. Based on your other question you've used composer to install, and then likely used drush to enable the civicrm module. If you do that you need sometimes to pass the -l parameter to drush otherwise it puts "default" in for the domain name in civicrm.settings.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.