2

Drupal 7, Civi 7.x-5.11.0

I've installed the latest webform module and the most recent webform_civicrm from Github.

I'm getting the following error when submitting or trying to access webform submissions:

Error: Call to undefined function wf_crm_apivalues() in webform_civicrm_webform_submission_load() (line 316 of /sites/all/modules/webform_civicrm/webform_civicrm.module).

Any ideas where I can look or advice to fix?

Thanks, Davy

5

Thanks for letting us know about the problem. I've just pushed a fix into the 7.x-4.x branch to ensure the function gets loaded. You can update your local copy of the module (cd /path/to/modules/webform_civicrm && git pull) and try again.

| improve this answer | |
  • Hi Coleman - thank you very much for helping out so quickly. – Davy Ivins Apr 4 '19 at 20:27
1

If you've installed from github you're installing a beta or maybe even alpha version. In fact I can see that line 316 listed in the error message was only added 6 days ago! There are links at the bottom of the drupal project page to stable versions - use those instead. https://www.drupal.org/project/webform_civicrm

| improve this answer | |
  • Thanks Demerit for getting to this first; I’ll check with Coleman on line 316 😀 – KarinG - Semper IT Apr 4 '19 at 0:22
  • Thanks Demerit - I used the Github version because it has fixes for other functionality I needed eg github.com/colemanw/webform_civicrm/pull/182 I hope I'm not creating more challenges for myself :-/ – Davy Ivins Apr 7 '19 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.