3

I don't know why it would want to delete a payment processor type, but it did. I ended up clearing the civicrm cache again and running the upgrade again - this time with no issue.

error backdrip

  • Has everything been working fine since the upgrade? We have hit the same issue as well. – Andy Burns Apr 11 at 13:18
  • so far so good. – themak Apr 15 at 17:04
3

The recent civi upgrade tries to disable some obsolete extensions during the process. This functionality was added in https://github.com/civicrm/civicrm-core/pull/13298

And from the comment posted at https://github.com/civicrm/civicrm-core/pull/13298#issuecomment-462961558, it seem it do provides a list of extensions that will be disabled.

The above error seems to be triggered when an extension related to payment processor type is disabled which in turn tries to remove the payment processor type attached to it.

Not completely sure, but this is what it seems from the backtrace shown.

UPDATE -it looks like there are 4 noted extensions which are checked by the above PR during the upgrade process.

uk.squiffle.kam, com.aghstrategies.slicknav, de.systopia.recentitems, and com.ixiam.modules.quicksearch.

If any of the extension is present on the site, it will try to disable them which throws the error on upgrade.

Note that none of these extensions are related to any payment processor.

So, it must be something in your DB which mismatches with the expected values resulting into this error. Would recommend disabling these extensions manually before starting an upgrade process.

  • We had uk.squiffle.kam active when upgrading and experienced a failure then cleared cache and ran upgrader again, so this answer makes sense. It would have been nice to have warning on doing this step before upgrade. Everything seems to be working, except some user permissions were changed... – Andy Burns Apr 12 at 13:06
  • This seems to be 2 issues that may or may not be related. There is automatic disabling of obsolete extensions in 5.12 (and in our testing it did not cause any crashes or problems during upgrade, sorry to hear you had trouble with it @AndyBurns) and there is something going on with payment processors. Not sure what the deal is there. – Coleman Apr 12 at 21:35
1

I had a similar experience. Flushing cache didn't do it for me (I tried 'cv flush', too). Found this: https://github.com/ixiam/com.ixiam.payment.redsys/issues/24 and tried deleting the payment processor records in table civicrm_managed. Upgrade went ok after that. The records were for the iATS payment processor, which I had recently tested but am not actively using. It looks like they were recreated after the upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.