1

So we are playing around with extensions that might help us, and tried to install civivolunteer. It is on my extension list, and the option is to "install". When I click this I get an error about Field: name must be unique. An conflicting entity already exists - id: 113

Other people have had similar errors, however, we have an additional issue. We now have the option to create a volunteer, we now have search options related to volunteers, but we do not have any civivolunteer menu options. We want all this stuff gone if we can't install it, we only really wanted it to try and track volunteer times, and this "half install" is not helpful. We want to uninstall it , but as I said above it only gives us the option to install it.

We have tried looking in /var/www/sites/all/modules/civicrm/ext$ but I cannot find the extension to just try and remove it like that. Where would it be installed? How can I get rid of these leftover parts of the volunteer extension?

2

Go to the extensions page (Administer > System Settings > Extensions) then click the arrow/triangle next to the extension name to expand the section. That will show Local path where the extension files are.

Just removing the files won't remove the leftover bits of the extension from the database. If it is partially installed but doesn't offer the option to uninstall then things are more awkward. If you have command line access you could try cv ext:uninstall .... Failing that you need to look at the install script in the extension, figure out what it adds to the db then manually remove those things.

  • I cant delete the folder, not got permissions for where it is, which I can try to fix later. I will look at the cv ext uninstall? not sure how to use that but I'll hve a look – user6861 Apr 12 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.