0

I'm wondering if anyone is experiencing a similar issue. I upgraded to 5.12 this morning and now it seems contact images are not displaying...

I grabbed the url /wp-admin/admin.php?page=CiviCRM&q=civicrm%2Ffile&reset=1&filename=imageName.jpg&mime-type=image/jpeg&reauth=1

To see if I could access the image, but it downloads an unreadable file.

I have tried deleting a contact image and uploading a different one with the same results, and it does seem as though the images exist on my file system....

Any thoughts would be appreciated

  • I've done a little more digging and it doesn't look like a civicrm_file record is being created in the DB. – Brad Apr 14 at 2:51
  • I've done a little more digging and realised the contact image is stored directly in the civicrm_contact table. the URL for the contact image is stored, however when I follow the link I get the following message You do not have permission to access this content. So I guess its a privacy setting somewhere? civicrm/?page=CiviCRM&q=civicrm%2Fcontact%2Fimagefile&photo=image.jpg – Brad Apr 14 at 3:06
  • Are you logged in as user 1 or administrator user? – Pradeep Nayak Apr 14 at 7:32
  • I tried as admin and as a generic user. – Brad Apr 15 at 7:32
  • 1
    Your SSL certificate is not verified, contact your ssl provider or system admin to get it verified – Pradeep Nayak Apr 18 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.