3

Is there an SHA-512 replacement for the AuthorizeNet.php module yet? If not I can work on it

2

Lesley, CiviCRM 5.11.0 doesn't use anymore MD5 check on authorize.net. This PR removes the check. However there is still not PR submitted by anyone to support SHA-512 check.

If you can submit a PR to support this would be very useful to the community.

Cheers

Pradeep

| improve this answer | |
  • 1
    Hi Pradeep I can work on it - it would be a patch that would need to also allow Admin/Process Payment form to input SHA-512 key, not just update AuthorizeNet.php. In the meantime, thank for pointing out the latest pull request. – Lesley Evensen Apr 16 '19 at 16:02
  • I have submitted fixes in the past using Issue Tracker, and I see that now Civicrm is using Gitlab, not JIra, etc. I 'joined'/registered, but now, do I need to 'request' joining a group? Can I not simply submit this as an issue for review, this is an update, not an extension. Can you send me the url I need to go to 1) submit this change as an issue and 2) git clone the latest release? – Lesley Evensen Apr 17 '19 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.