Configuration: Wordpress 5.1.1, CiviCRM 5.10.3

We needed to edit a link in our Scheduled Reminders and discovered we can no longer do so. This is the behavior:

We can edit these reminders just fine, but when we select linked text to edit (or to add a new link), I cannot put the cursor in the edit box to make the edit (see 1st screenshot below). That seemed strange so I clicked on the "Source code" edit button and, once again, I could not place the cursor in the window to make the edit (see 2nd screenshot below). I then checked the ability to edit in CiviMail and also in CiviEvents. I had no problem editing/inserting links there.

I thought this must have something to do with TinyMCE editor or possibly some weird conflict with our Wordpress theme, or even conflict with a block editor that we use (Elementor). I changed to a pure vanilla WP theme (2019) and deactivated Elementor. No dice. Thinking that it was TinyMCE, I upgraded Civi to 5.12.3. All these things did not fix this strange behavior.

Wordpress 5.x was a major upgrade regarding editing where they are pushing their Gutenberg block editor, so maybe this started when we upgraded to 5.x, but there's no turning back at this point, but I suspect there is some weird TinyMCE mess up somewhere and have no clue why it would only show up in editing Scheduled Reminders, whereas all edit functionality in CiviMail and CiviEvents seems to be working.

Any clues would be helpful. We NEED to edit our reminders as our special renewal contact links display weirdly under a recent WP theme change we made and we have it fixed by just pointing the contact link to a different page.

Cannot edit the link in the edit link dialog

Cannot edit the source when Soure code edit button is clicked

  • Snoooping around, I discovered a work-around. Noticing that TinyMCE is an installed extension, I just disabled it. I was then able to edit Scheduled Reminders links just fine. I have always gone with the basic core install. What is the disadvantage of disabling TinyMCE? I hesitate to post this as an Answer, but it is an obvious temporary workaround. Apr 22, 2019 at 2:30

1 Answer 1


OK, I'm going to be bold and answer my own question. According to https://civicrm.org/extensions/tinymce, starting with CiviCRM 4.7, an internal editor CKEditor was provided to handle all Civi backend editing. Since we started using Civi prior to that, we had the TinyMCE extension installed and I should have been aware to disable TinyMCE in favor of the default CKEditor at that time.

I'm interested if anyone else has anything to add. At the very least this post does note an evident TinyMCE bug with our Wordpress/CiviCRM versions configuration.

  • 1
    From a user's point of view you are correct, CKEditor is the only "officially supported" editor for CIviCRM and if you use anything else, you're on your own. From the POV of the maintainers of the TinyMCE extension though, this is just a bug and should be fixed fairly easily if anyone is at the helm of that extension. But I'm not sure anyone is.
    – Coleman
    Apr 22, 2019 at 17:11
  • If someone can refresh my memory back to the Civi 4.7 upgrade (I'm starting to suffer from CRS - can't remember s--t) ... During that upgrade, did it ask or at least warn us to disable the TinyMCE extension? Apr 22, 2019 at 17:15
  • I also referenced this post on the github account for the TinyMCE extension so the developer(s), if active, can address. Apr 22, 2019 at 17:45
  • 1
    No, the timymce extension did not exist prior to 4.7. In 4.6 and below, tinymce and ckeditor were both bundled in civicrm core. To keep using tinymce when you upgraded to 4.7 you would have had to download and install the extension yourself.
    – Coleman
    Apr 22, 2019 at 19:26
  • So, I, myself, and I am the culprit. I probably installed TinyMCE because I didn't want to change the edit interface for our staff, who do not know under-the-hood details of either WordPress or Civi - they just need to get their job done. Lesson learned on my part. Thanks for the refresh ;) Apr 22, 2019 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.