1

i use wordpress 4.2.2 and civiCrm 4.6.3. I have created a file CiviCron.php:

// create a new cURL resource
$ch = curl_init();
// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, "http://www.auroratrezzo.it/wordpress/wp-content/plugins/civicrm/civicrm//bin/cron.php?name=user&pass=password&key=key-site");
curl_setopt($ch, CURLOPT_HEADER, 0);
// grab URL and pass it to the browser
curl_exec($ch);
curl_close($ch);

I have configurated cPanel cron job:

php /home/informac/CiviCron.php

I recived this error:

<br />
<b>Fatal error</b>:  Function name must be a string in <b>/home/informac/public_html/wordpress/wp-content/plugins/section-widget/olt-checklist/loader.php</b> on line <b>64</b><br />

Why ??

Marco

4

The error seems to come from something unrelated to civi:

plugins/section-widget/olt-checklist/loader.php

Can you try to disable this plugin and see if it works?

| improve this answer | |
0

Another thought is to do this with wp-cli (WordPress drush equivilant). This way you can tell wp NOT to load any plugins with fatal errors.

The standard syntax I use is:

wp --user=<cron> --url=<http://example.com> --path=</path/to/wp> civicrm api job.execute auth=0

You can also do this to exclude plugins:

wp --user=<cron> --url=<http://example.com> --path=</path/to/wp> --skip-plugins=<plugin> civicrm api job.execute auth=0

By adding --skip-plugin= you can get rid of the nasty plugin causing the error. Of course, removing plugins with fatal errors is preferred, but sometime we need to keep them around.

I have also added this to http://wiki.civicrm.org/confluence/display/CRMDOC/Managing+Scheduled+Jobs

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.