2

After upgrading to 5.12.1 (and then 5.12.3), none of the dropdown options under "Actions" work. For example, when conducting an Advanced Search and selecting, "Print/Merge Documents" or "Export Contacts," nothing happens.

Here is the console error:

main-menu.js?r=dBZqC:66 Uncaught TypeError: Cannot read property 'trim' of undefined
    at isQuickSearchOnGoing (main-menu.js?r=dBZqC:66)
    at HTMLDocument.<anonymous> (main-menu.js?r=dBZqC:99)
    at HTMLDocument.dispatch (jquery.min.js?r=dBZqC:3)
    at HTMLDocument.r.handle (jquery.min.js?r=dBZqC:3)
    at Object.trigger (jquery.min.js?r=dBZqC:3)
    at HTMLInputElement.<anonymous> (jquery.min.js?r=dBZqC:3)
    at Function.each (jquery.min.js?r=dBZqC:2)
    at n.fn.init.each (jquery.min.js?r=dBZqC:2)
    at n.fn.init.trigger (jquery.min.js?r=dBZqC:3)
    at n.fn.init.n.fn.<computed> [as click] (jquery.min.js?r=dBZqC:4)

Any insight would be greatly appreciated!

  • 1
    Try Clear Caches (administer - system settings - Cleanup Caches)? Also try to empty the templates_c folder? – Demerit Apr 24 at 23:23
  • @Demerit Tried those already and again today--no luck! – raaboyl Apr 25 at 13:26
3

The problem was a conflict with the CiviCRM Bootstrap Theme. Disabling the extension resolved the problem.

  • Worked for me also to fix, but other extensions like Mosaic are dependent on the CiviCRM Bootstrap Theme extension. Had to disable, used the 'action' and then re-enabled. – ChaosBuster Apr 29 at 16:53
  • It's my understanding that the extension is only supported for Drupal, so if you're using Wordpress it should be safe to leave disabled. – raaboyl May 2 at 16:29
  • Not what I observed in WordPress. The Mosaic extension is dependent on it. – ChaosBuster May 3 at 20:07
  • Have same problem with 5.13.5 and Drupal. Need to restore Shoreditch - any suggestions on solution that does not required disabling shoreditch? – Dave T Jun 4 at 19:26
  • Solved problem by disabling Shoreditch (Bootstrap) extension, disabling CiviCRM css on Settings - Resource URLs page, clearing caches and then reversing the above steps. Most likely it was the disabling and re-enabling of Shoreditch/Bootstrap extension but cannot be certain. Clearing caches alone did not fix the problem. – Dave T Jun 5 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.