2

I tried to get the CiviCRM LDAP integration working.

I used the LDAPcivi 'extension' (GitHub). And got it running quite quickly. But when I tried to connect with Thunderbird I ran into trouble. This is what the server showed me.

bind dc=[domain name of civicrm site], dc=[tld]:[password]
searching 100
[ 'title',
  'sn',
  'surname',
  'mozillahomelocalityname',
  'cn',
  'commonname',
  'givenname',
  'mozillahomestate',
  'mail',
  'mozillaworkurl',
  'workurl',
  'labeleduri',
  'o',
  'company',
  'mozillahomestreet2',
  'mozillanickname',
  'xmozillanickname',
  'mobile',
  'cellphone',
  'carphone',
  'modifytimestamp',
  'nsaimid',
  'nscpaimscreenname',
  'telephonenumber',
  'birthyear',
  'c',
  'countryname',
  'mozillahomestreet',
  'postalcode',
  'zip',
  'mozillacustom1',
  'custom1',
  'mozillahomecountryname',
  'st',
  'region',
  'mozillacustom2',
  'custom2',
  'mozillahomeurl',
  'homeurl',
  'mozillaworkstreet2',
  'mozillasecondemail',
  'xmozillasecondemail',
  'facsimiletelephonenumber',
  'fax',
  'description',
  'notes',
  'mozillacustom3',
  'custom3',
  'homephone',
  'mozillausehtmlmail',
  'xmozillausehtmlmail',
  'birthday',
  'street',
  'streetaddress',
  'postofficebox',
  'mozillacustom4',
  'custom4',
  'l',
  'locality',
  'pager',
  'pagerphone',
  'ou',
  'department',
  'departmentnumber',
  'orgunit',
  'birthmonth',
  'mozillahomepostalcode',
  'objectclass' ]
query DN = dc=[domain name of civicrm site], dc=[tld] sub / And
(&(|(cn=*ldap*)(givenname=*ldap*)(sn=*ldap*)(mozillanickname=*ldap*)(mail=*ldap*)(mozillasecondemail=*ldap*)(&(description=*ldap*))(o=*ldap*)(ou=*ldap*)(title=*ldap*)(mozillaworkurl=*ldap*)(mozillahomeurl=*ldap*)))-> searching And for ldap
searching ldap
civicrm_contact_search failed: couldn't parse {"is_error":0,"undefined_fields":["contact_is_deleted","cms","contact_type","sort_name"],"version":3,"count":1,"id":5,"values":[{"contact_id":"5","sort_name":"API, LDAP","display_name":"LDAP API","contact_type":"Individual","first_name":"LDAP","last_name":"API","job_title":"","organization_name":"","contact_is_deleted":"0","current_employer":"","address_id":"","street_address":"","supplemental_address_1":"","city":"","postal_code":"","state_province_id":"","country_id":"","phone_id":"","phone_type_id":"","phone":"","email_id":"","email":"","state_province_name":"","state_province":"","country":"","id":"5"}]}
civicrm_contact_search failed: unknown error

So. It actually manages to get a good search result. But somehow it isn't able to send it to Thunderbird. Maybe I'm missing out something obvious!

Hope someone else already got this LDAP thing running, and is able to help me out.

I also opened an issue on GitHub concerning this problem.

Maybe LDAPcivi is too old. I saw it was mentioned a bit more recently on this forum, so I hope that is still usable!

All the best,

1

For some reason, I didn't receive a notification on the ldap github repo, thanks to raise it here!

I answered on the issue in github, let's follow there?

I never tried civildap on wordpress, I don't know if it's why it has some issue. To exclude some potential sources of the problem, could you change your config file and put:

settings.civicrm.action = "get"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.