4

Testing use of recaptcha v2. Have set up on site (Civi 5.12.3) and it is showing up on contribution pages as expected.

On Google site, shows this message.

We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site. Please see our developer site for more information.

Any suggestions or ideas on what might be missing?

7
  • Did you ever figure this out?
    – guyiac
    Jun 15 '20 at 20:40
  • Did not "figure it out" but did try again a few weeks ago with what I believe is a new version on the Google side. Repeated installation via profile, etc. with Civi and have been successful. Suspect it was Google update but cannot say for sure. Are you having a problem?
    – Dave T
    Jun 16 '20 at 13:31
  • Correction, did a test yesterday and today the Google site error has returned (or never left) "We detected that your site is not verifying reCAPTCHA solutions" Do you have the same issue?
    – Dave T
    Jun 17 '20 at 9:25
  • Frustrating. I'm getting it for some clients, but not for others, and I haven't been able to figure out a pattern yet, if there is one.
    – guyiac
    Jun 27 '20 at 15:28
  • Correction: We are getting the message that you cited on the reCAPTCH admin page in Google for any client site that has any reCAPTCHA requests (those with no requests don't show the message, which makes sense). So I think it might be something in the Civi code that needs to be changed per here: developers.google.com/recaptcha/docs/verify#api-request. Want to talk about splitting the costs to have our dev research and submit a patch?
    – guyiac
    Jun 27 '20 at 15:38
2

This has been fixed recently as a bug. I would expect to see this in 5.32 or 5.33. It may make a patch release and be available sooner.

Link to PR

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.