1

I am running CiviCRM under WordPress on a local host

I have set up a Group named "Mailing List" with "Join Our Mailing List" as the description.

Under Group Type "Mailing List" is checked - and I've tested with "Access Control" both checked and unchecked. Visibility is set to "Public Pages". Reserved Group? is unchecked. Is Active? is checked.

I can enter contacts in the back end on Word Press and they appear as contact in CiviCRM, but there is no box on the front end --something that will appear to a user who is not logged in -- in which a user can enter himself as a contact. What must I do to get a box in "Public Pages" where a visitor can enter his name and email address and have this information become part of the CiviCRM mailing list group?

1

As peterdnz says, the documentation is at https://docs.civicrm.org/user/en/latest/email/set-up/ (Using a Profile). For WordPress I think the easiest way to display a form publicly is by using a shortcode. After preparing a WordPress Page, click the CiviCRM button above the editor. For Page Type select Profile. On the next drop-down that appears, select the name of the profile that you have created. Select Edit on the radio button option just below the drop-downs, so that you give users access to edit data in your database (i.e. to add their email address and name to your database). Click Insert Form and the shortcode will be added to the editor. Hope this helps

  • 1
    Be aware that the CiviCRM button isn't there in the new Block Editor so you have to use the Classic Editor. – Mick Kahn May 6 at 12:48
  • Thanks, Peterb! The link you sent me solved my problem. – Sunfire May 28 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.