1

I am trying to set up a workflow with CiviCase to automatically file clients' responses on their respective cases.

According to the documentation, mails arriving in the e-mail-to-activity-Mailbox, containing the pattern [case #123] in their subject line, get automatically filed under the respective case (123 in this case) as an activity ('Incoming E-mail').

This is all working fine so far regarding the overall process. However, the contents of the incoming mail is not visible in the 'details' section of the activity. An attachment with the mail gets created, but with the extension '.unknown'. I can download this attachment, manually select a program to view it (e.g. a text editor) and (only) the body of the mail gets displayed as plain text, the header info seems to be stripped off. This behavior happens for html mails as well as plain text mails.

What I originally expected was something like a plain text representation of the mail under details, the same way as it is handled with outgoing mails. And the attachment should ideally contain the unaltered and entire mail, including the header information (date/time, recipients) and have a filename extension which could be recognized by a mail client after download (e.g. .eml).

My main question for now: Is this the intended behavior (then I can arrange to live with it, since I am quite happy with the overall process) or am I missing some configuration settings somewhere?

(Using CiviCRM 5.13.1 and Wordpress 5.1.1)

  • Hmm, I'm able to reproduce this using both thunderbird and gmail. Something must have changed. I'll file a bug at lab.civicrm.org. So it's also not specific to wordpress. I'm guessing your civi version is 5.13.1 but I'm seeing it in the latest dev too. – Demerit May 6 at 15:52
  • Thanks a lot for your effort! – Joachim May 6 at 19:58
1

Regarding the ".unknown", you can update the list of extensions it recognizes at Administer - System Settings - Safe File Extensions.

Regarding the rest that isn't how it used to work. Not sure if something's changed recently or maybe there is something unusual about those emails. You say it's both html and plain - are all the emails coming from the same source or different types of sources, e.g. MS Exchange, gmail, etc.

UPDATE: https://lab.civicrm.org/dev/core/issues/940

  • Thank you for your extremely quick response! Just to clarify: The .unknown extension is the name/extension of the activity attachment, which contains the incoming mail. It gets created by civi, which then attaches it to the newly created activity. The email as such does not contain any attachment. Therefore, I don't think the safe file extension can help. I tried to send test mails from various addresses. They got created with Thunderbird, so nothing fancy. – Joachim May 6 at 15:17
  • I mean .unknown is what civi puts when it sees an attachment that isn't in that list, so if it thinks it's ".eml" for example, it would put ".unknown" if that isn't in the list. Although you say there is no attachment. (Except technically there is no difference between mime parts and attachments, so even html can be considered an "attachment" depending how the email is formatted.) In thunderbird in your sent folder can you view source (CTRL-U) and see what the mime parts are? The lines that start with "Content-Type:" – Demerit May 6 at 15:28
  • The following is the available information regarding the mime parts: Content-Type: text/plain; charset=utf-8, i.e. just the most basic variant. - This should probably not be the cause for the effects. – Joachim May 6 at 19:55
  • @Joachim it sounds like there might be a release in the next day or so that has this fix. Thanks for reporting. – Demerit May 6 at 22:39
  • This should be resolved in 5.13.2 which has just been released – Seamus Lee May 7 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.