0

I am currently trying to setup an online membership signup form for our organisation.

I am in the early stages at the moment but so far I have created the bare bones of the form by creating a profile containing the various fields that need to be on the form. After doing this I wanted to test completing the form online so that members / organisations are added to Civi. When clicking on Use - Create mode I am able to view the form and complete it etc (This only appears however to be when I am still logged into my session). If I try the URL in private mode or on a difference browser then I get the following error:

(Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. The requested Profile (gid=16) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance.)

enter image description here

What could be the cause of this?

The other issue I am coming across is that I want to use this profile via a Contribution page, however when setting up the Contribution page, under the profile tab section, the drop down Include Profile (top of page) will not list the profile I have created so I cannot add it.

As per below I have created a profile called "Membership Form" however this profile is not showing in the dropdown list to add to the Contribution page.

enter image description here

enter image description here

Any help would really be appreciated - I am pretty new to CiviCRM.

Thanks in advance everyone :)

1

For the first part, see if this answer helps: https://civicrm.stackexchange.com/a/22434/225

For the second part where the profile is not showing up, that can mean that you have added fields that are not valid in the context where you are trying to use the profile. Civi determines the type of the profile based on the fields it contains, so adding fields can reduce the places where it can be used. Looking at your screenshot shows Testing_Only in the type so look at your fields and remove whatever relates to Testing_Only and see if that results in the profile showing up where you want it.

  • Thanks Aidan that is really helpful. – TCVTerry May 8 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.