1

I created a set of custom questions that are of the type multiple choice. I entered the labels like "Blue", "Green", "Orange", and left the values at 1,2,3

When I run a report in civiCRM, the column for my multiple choice question shows the label.

But, when I export the data, I see the corresponding values (1,2,3) instead of the labels.

But I need the label in my report, not the values.

Thought maybe I could just edit the multiple choice answers and copy the label text to the value column, but realized that the values 1,2,3 were being stored in the database in the custom data set civicrm_value_ table, so when I run the report in civiCRM, the column for the multiple choice question was blank (and no value was exported).

Trying to resolve this, I thought maybe I could update the column in the civicrm_value_ to store the value (replacing 1 with "Blue", 2 with "Green", 3 with "Orange").

But same result -- blank column in the report.

So question is -- how can I fix my problem? I need to update the multiple choice and copy the label to the value field, and update the existing data submitted so that it has the new text value instead of the old numeric value...

1

This is definitely bug in report. You can either fix the code so that it is exported as label or use the same text for label and value for the options when creating.

Eg For Blue use Label - Blue and value - Blue.

  • 1
    Overwriting field value risks losing existing data- or it did a couple of years ago when I did it. Labels can be renamed safely – Craig Almond May 10 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.