2

I am trying to configure an Event to repeat on every second Sunday but upon saving the event it shows incorrect dates in the Confirmation screen where it shows the same start date for each month and upon confirming it gives an error stating "Invalid day name". I tried by giving other day and it is working correctly but not for "Sunday". This was on CiviCRM version 5.10.3. I tried by upgrading to 5.13.2 but the issue was same in that also. I am not sure what I am missing. Kindly help me to fix the issue.

Repeating event configuration

Incorrect start date in confirmation screen

Invalid day name error

3

I'm thinking the invalid day name error is the result of the start date of June 10, 2019 which is a Monday, not a Sunday (note that in your screenshot, there is no date listed for the "Original" event). If you change the start date to June 9 (which is the second Sunday in June), then the repeat function works as expected (on 5.10.alpha1):

enter image description here

Hope this helps, Tamar

  • Tried this on 5.13.1 and works perfectly picking a start day of Sunday May 26 – Andy Clark May 16 at 21:15
  • @Tamar Thanks for the reply, I tried by changing the start date to June 9 but it resulted as it did before where the confirmation screen showed same start date for each month and then gave "Invalid day name" error. The start date was empty for the 'Original' event – Vikas BN May 18 at 4:41
  • @VikasBN Make sure that the event start date on the Info and Settings tab is also June 9 - if that doesn't work, try creating an entirely new event and make sure that the event start date is also June 9 - if neither of these work then there must be something specific to your environment that is causing this as two of us were unable to reproduce on either 5.10 or 5.13 environments. – Tamar Meir - Cividesk May 20 at 16:36
  • 1
    @TamarMeir-Cividesk I resolved the issue by changing the "Week begins from" value in Date format settings to "Monday" and then changed it back to "Sunday", this fixed the issue. – Vikas BN Jun 10 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.