1

I am trying to get CiviCRM working against Drupal 8.

For testing and setting up I am currently using:

  • Oracle VBox 6
  • UBuntu 18.04
  • php 7.2.17
  • mysql 5.7.26
  • composer 1.8.5

Let me know if there is anything else relevant or if the above combination does not work.

I am trying to follow David Snopek's latest how to https://www.mydropwizard.com/blog/better-way-install-civicrm-drupal-8

In it David gives the following example:

composer create-project roundearth/drupal-civicrm-project:8.x-dev some-dir –no-interaction

As I am aiming for something as stable as possible while still on the bleeding edge. (I know that is a contradiction)

I used the following in the /var/www/html

composer create-project drupal/drupal /var/www/html/drupal

I then went in via my browser and set up Drupal 8 with a standard install. I did not add any modules etc. So now I have Drupal 8.7.0

I then used the following composercommand while in the /var/www/html/drupal directory. see screen output below:

peter@UbuntuVM:/var/www/html$ cd drupal
peter@UbuntuVM:/var/www/html/drupal$ composer require roundearth/civicrm-composer-plugin civicrm/civicrm-drupal-8
Using version dev-master for roundearth/civicrm-composer-plugin
Using version dev-master for civicrm/civicrm-drupal-8
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - civicrm/civicrm-core 5.9.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.9.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.9.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.8.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.8.2 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.8.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.8.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.7.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.7.3 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.7.2 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.7.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.7.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.6.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.6.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.6.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.5.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.5.3 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.5.2 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.5.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.5.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.4.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.4.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.4.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.4 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.3 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.2 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.12.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.11.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.11.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.x-dev requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.4 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.3 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.2 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.1 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - civicrm/civicrm-core 5.10.0 requires zetacomponents/mail dev-1.7-civi -> no matching package found.
    - Installation request for civicrm/civicrm-drupal-8 dev-master -> satisfiable by civicrm/civicrm-drupal-8[dev-master].
    - Conclusion: remove psr/log 1.0.2
    - Conclusion: don't install psr/log 1.0.2
    - civicrm/civicrm-drupal-8 dev-master requires civicrm/civicrm-core >=5.4.0 -> satisfiable by civicrm/civicrm-core[5.10.0, 5.10.1, 5.10.2, 5.10.3, 5.10.4, 5.10.x-dev, 5.11.0, 5.11.x-dev, 5.12.0, 5.12.1, 5.12.2, 5.12.3, 5.12.4, 5.12.x-dev, 5.13.0, 5.13.1, 5.13.2, 5.13.3, 5.13.4, 5.13.x-dev, 5.14.x-dev, 5.4.0, 5.4.1, 5.4.x-dev, 5.5.0, 5.5.1, 5.5.2, 5.5.3, 5.5.x-dev, 5.6.0, 5.6.1, 5.6.x-dev, 5.7.0, 5.7.1, 5.7.2, 5.7.3, 5.7.x-dev, 5.8.0, 5.8.1, 5.8.2, 5.8.x-dev, 5.9.0, 5.9.1, 5.9.x-dev, dev-master].
    - civicrm/civicrm-core 5.13.0 requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.13.1 requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.13.2 requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.13.3 requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.13.4 requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.13.x-dev requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core 5.14.x-dev requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - civicrm/civicrm-core dev-master requires psr/log ~1.1 -> satisfiable by psr/log[1.1.0, 1.1.x-dev].
    - Can only install one of: psr/log[1.1.0, 1.0.2].
    - Can only install one of: psr/log[1.1.x-dev, 1.0.2].
    - Installation request for psr/log (locked at 1.0.2) -> satisfiable by psr/log[1.0.2].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.
peter@UbuntuVM:/var/www/html/drupal$ 

I know its a lot but any ideas on how to make this work with a standard drupal 8?

Thanks Peter

2

You can specify the version of civi you want if it can't figure it out, so e.g.

composer require roundearth/civicrm-composer-plugin civicrm/civicrm-drupal-8 civicrm/civicrm-core:5.13.4

You might also have to add and specify the psr/log version on the same line to match, based on the error message above.

  • Thanks for the hint. I will be trying some combinations to see what works. – Peter May 17 '19 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.