1

Really hoping you can help with this.

We had a security update on Civi yesterday which appears to have caused an issue with how one of our tokens is pulling through to a mailing template.

We used a token of {membership.start_date} which pulls through a groups membership start date onto the mailing template. The dae itself is held at the following location:

enter image description here

Unfortunately I was not at this company when this was setup so I am unsure how the link between the token and the membership start date has setup and why it has suddenly broken down.

If you could please provide some advise or point me at which settings to look at it would be really great.

Thank you all, Terry

.......................

Update - Error being received below when trying to install the "Fuzion Tokens" extention.

enter image description here

..............................

Further to the above it appears that the tokens are pulled via the Scheduled reminder templates, E.g:

{membership.end_date} {membership.start_date} {membership.join_date}

However when testing these via scheduled reminders and mailing templates the fields are all not pulling through from the membership details now. I have looked though out modules on Drupal and and their is a tokens module present, however I am unsure how to access the details of this / the GUI to view or edit any tokens that have been created for example.

All other tokens continue to work, such as contact tokens, presume that these are Core Civi tokens however.

Really starting to pull my hair out with this now as to why all of a sudden just the membership tokens have stopped working.

Any help would be greatly appreciated.

  • Have you tried using Find Members to then build a new template and confirm if the tokens work there or not? – petednz - fuzion May 20 at 21:48
0

Basically: Such a token is not available in CiviCRM core, so most probably it was added with an extension. So you might check your extensions, whether there exists something that sounds like %token%.

How old was your installation? If it were very old, the extension might have been written as a drupal module, and maybe something broke with that.

As a solution: You might install the extension "Fuzion Tokens", which includes lots of very helpful tokens, especially the token {latestcurrentmembership.start_date}. (this "latest current" deals with the case, that technically a contact might have several memberships, and CiviCRM wouldn't know which one to use).

  • Hi, Thank you for your help. I have checked our extensions and none of them would appear to be relevant to tokens. I believe the installation is very old yes, unfortunately I cannot be certain though as all the IT staff that would have dealt with it are no longer at the company, – TCVTerry May 19 at 15:48
  • I have tried to add the "Fuzion Tokens" extension as this sounds like a very good solution, however when I try to download & install it I get the following error alerts come up (Please see screen snippet above on the main question). Thanks again for helping me with this, I really appreciate it. – TCVTerry May 19 at 15:51
  • 1
    Fuzion Tokens now installed and {latestcurrentmembership.start_date} being used to pull in the information. Thank you for your help, very much appreciated. – TCVTerry May 21 at 14:12
2

{membership.start_date} was never supported in token list for sending mailings unless you have any custom extension or module that generates one.

{membership.start_date} token is supported only in Schedule reminders(for memberships) or printing letters for membership.(i believe). The schedule reminder screen allows you to save the template so that it can be used in future. If you using the same message template to send mailings then the tokens other than contacts won't get replaced unless you have custom code that deals with such tokens.

Civitokens extension does allow some additional token like latest current membership which can be used in mailings however you will need to replace the existing token with the new ones.

The error message you posted seems like your server doesn't have permission for apache user to download/extract the extension from UI. Alternate way is to download the extension and extract into extension directory and install it manually.

HTH

Pradeep

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.