1

After upgrading to 5.13.4 all of Civi has disappeared to be replaced with the error

Fatal error: Class 'DB_DataObject' not found in /var/sites/c/[site]/public_html/sites/all/modules/civicrm/CRM/Core/DAO.php on line 49

I first noticed it trying to visit /civicrm/upgrade?reset=1 after uploading all the updated files, but it appears trying to load any part of CiviCRM. Drupal (7.67) still loads fine, though it's still in maintenance mode at the moment.

And ideas what's gone wrong?

  • 1
    can you delete the existing civicrm folder and untar it from here download.civicrm.org/civicrm-5.13.4-drupal.tar.gz and perform upgrade? – Pradeep Nayak May 17 at 16:15
  • Huh. That worked. For some reason I'd got it into my head early on in evaluating CiviCRM that my shared hosting wouldn't let me untar over SSH, so I've always uncompressed locally, then FTPed the whole lot. But this time it worked, and I've no idea why that would be different. Guess something corrupted in my previous upload. Anyway, if you make that an answer I'll accept it. Thanks. – somnolentsurfer May 17 at 18:42
  • Wow. Added as an answer – Pradeep Nayak May 17 at 18:43
2

can you delete the existing civicrm folder and untar it from here https://download.civicrm.org/civicrm-5.13.4-drupal.tar.gz and perform upgrade?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.