We are moving our CiviCRM site over from Drupal to Wordpress. We have this fully working on our developer's server (nginx), but on our live server (Apache), we see an error when loading some CiviCRM pages.

Notice: Undefined index: path in /var/www/etcetcetcetc/wp-content/plugins/civicrm/civicrm/Civi/Core/Paths.php on line 200

You can see the error at https://culturalenterprises.org.uk/?page=CiviCRM&q=civicrm%2Fevent%2Finfo&id=285&reset=1

It also appears on some back end screens (attached below).

enter image description here

I have asked our developer to look into what is causing the error in the first place, but I am also completely unable to prevent display of the 'notice' error.

In wp-config.php I have:

ini_set('error_reporting', E_ALL );
define('WP_DEBUG', false);
define('WP_DEBUG_DISPLAY', false);

In civicrm.settings.php, I have added:

ini_set('error_reporting', E_ALL );

In php.ini, I have set:

display_errors = Off
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT

And I have also tried disabling all plugins other than CiviCRM in case one of them is overriding these settings.

Debug is off in CiviCRM settings, and it is 'Production' mode.

Is there anything else I can do!?


CiviCRM 5.13.4 Wordpress 5.2.1

  • Can you set wpconfig.php and civicrm.settings.php to the same as what you have in php.ini?
    – Demerit
    May 26 '19 at 13:49
  • Tried that a few times, but you're right it should be consistent, so I've done that now. Alas no change! May 26 '19 at 14:33
  • Can you resave the Directory and Resource URL from CiviCRM UI? And also Clear CiviCRM cache May 26 '19 at 15:50
  • @PradeepNayak Done both of those too 😬 May 26 '19 at 15:50

Resolved it - it was an ancient and unused bespoke CiviCRM extension. Disabling it solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.