4

I'm using Drupal 7 and CiviCRM version 5.13.4 and I'm having a problem with using Mosaico.

When I try to create new templates, I'm unable to add new images to them. I can't drag and drop any images or add them using the little upload icon.

When I try to do so, I get a 500 Error in the console.

 GET https://site.com/civicrm/mosaico/img?method=placeholder&params=300%2C200 500 (Internal Server Error)

I also get this error in the top right of the screen:

Failed to locate Mosaico graphics driver. Either "mosaico_graphics" is invalid or the autodetection failed.

I attempted a google on that error but it appears it's never been reported before which isn't very helpful to me.

Below is a screenshot on how the templates look to me if it's of any use:

enter image description here

Happy to answer any follow up questions! Thanks in advance.

7

I've just had a seemingly identical problem on upgrade to 5.13.5 (ImageMagick reported as missing when present & up to date).

Disabling Mosaico/Fleximailer/Shoreditch & then re-enabling them seemed to resolve the issue.

  • It's not just 5.13, I had the same issue with 5.11. Disable and Re-enable also fixed it for me. – tanbog Jun 3 at 5:35
  • Hi Bryan, I've tried what you suggested but I still can't upload images! What a nightmare! – Ember Jun 3 at 7:54
  • Same here on 5.7. Bryan's fix worked for me. – user7166 Jun 3 at 7:59
  • I've not had any problem with images. My paths & directories are default settings for this drupal install. I have had such problems on other sites when using custom settings or if the ownership of files or direcories need resetting to the web server user/group after an upgrade. – Bryan Jun 4 at 0:53
  • Hi Bryan, everything is the default settings for us too. The site is relatively new, recently changed the domain name so perhaps that is causing an issue somewhere although I wouldn't know where to look – Ember Jun 4 at 9:57
2

Most likely it's missing PHP's ImageMagick OR GD Extension, required for image manipulation.

One quick way to check phpinfo in drupal is to visit url https://example.org/admin/reports/status/php and see if you find imagemagick or GD related info.

enter image description here

  • Deepak, thank you for your suggestion but I do have ImageMagick installed on the server, you can see here - gyazo.com/498f5889bb086fbae27fb7f73dc226d6 Is there another possible cause of why images aren't able to be placed, is there some configuration that needs to be done perhaps? – Ember May 31 at 14:06
  • In that case php 500 error log should reveal the exact problem is. Could you check what it's complaining about. Drupal error reporting logs should also work. – Deepak Srivastava May 31 at 14:11
  • Other way be to debug along the lines of github.com/veda-consulting/uk.co.vedaconsulting.mosaico/blob/… and see why Imagick class isn't being loaded. Also if you search of PHP Imagick not being detected, you 'll find more help on steps to take. – Deepak Srivastava May 31 at 14:20
  • Could you tell me where the error log is please? I've scanned a few but haven't found anything as of yet. I turned on error logging in Drupal and got a few errors that I'll update my question with – Ember May 31 at 14:29
2

In my case, neither of the other answers solved the issue I was having although I'm sure they are also reasons why Mosaico might not be working!

In my case, it was due to a dodgy Drupal module that was injecting whitespace into all the images which caused them to break.

I set up a local copy of the site and enabled each module one by one until the images broke and then when I found the module it broke at, it wasn't hard for me to find the rogue PHP file.

There was two new lines before the opening PHP tag <?php and once I had removed this, Mosaico worked as it should normally.

  • What was the Drupal module that was causing this? I'm having similar issues. – josh Jul 3 at 0:31
  • It was one of the Gavias theme modules - Gavias shortcode. It could happen with any module though really which is annoying! It could also be the theme – Ember Jul 3 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.