5

With recent upgrade, CiviCRM showed me this message

Future versions of CiviCRM may require MySQL utf8mb4 support. It is recommended, though not yet required, to configure your MySQL server for utf8mb4 support. You will need the following MySQL server configuration: innodb_large_prefix=true innodb_file_format=barracuda innodb_file_per_table=true

Since I am on shared hosting plan, it is likely that the host will not update these global MySQL settings. I guess that can mean for me the end of updates or a very tedious task of migrating CiviCRM elsewhere.

Is there any information when these MySQL changes will become mandatory?

7

It seems like it's still under discussion as of last week. See e.g. https://lab.civicrm.org/dev/core/issues/979

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.