2

we have a CiviCRM installation under WordPress 4.9.10 and 2 MySQL db: one for Wordpress and one for CiviCRM. Actually we imported and start to manage more than 5000 contacts.

Everything operate as well, excepting the following actions, returning us a

Network Error Unable to reach the server. Please refresh this page in your browser and try again.

  • clicking to go on page 2 on a "Search -> Find Contacts" or a "Search -> Advanced Search"
  • adding a meeting or phone call in the contact summary.

There are NO ERRORS adding contributions, registering for events, adding pledges, sending emails.

We see no errors in apache logs too. Actual PHP variables are:

 php_value memory_limit 256M
 php_value max_input_vars 2500
 php_value upload_max_filesize 16M
 php_value register_globals off
 php_value max_execution_time 600
 php_value output_buffering 0

Any ideas about to solve it? TIA -- Francesco

  • 1
    I think that this has a fix that is merged - but possibly not in this months release but next. It's about your server config - you have something called 'Full Group By' mode enabled in mysql. There is a patch if you feel comfortable backporting - well that goes for the paging bug - this one "adding a meeting or phone call in the contact summary" - I'm not so sure about - seems different & unrelated – eileen Jun 6 at 11:17
  • Trial done! I confirm that disabling the ONLY_FULL_GROUP_BY with this command mysql > SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY','')); solve the problem about the paging, but doesn''t solve the problem adding a meeting or phone call in the contact summary. – Francesco Garganese Jun 6 at 12:55
  • @FrancescoGarganese Could you please repost your comment as an answer below? Thanks! It might also help to post the problem adding a meeting/phone call as a separate question since it appears to be a separate issue. – Jon G - Megaphone Tech Jun 6 at 14:31
  • On the other issue - it's going to be necessary to capture some more debugging info - with debugging enabled you might be able to get it in your browser by inspecting the response – eileen Jun 7 at 0:12
  • Today i try to prepare a small video showing the error, posting to share to you all. Let me know if I can try something to obtain debugging info. About ONLY_FULL_GROUP_BY disabling it is a workaround, not a solution; but I put an answer to the question. – Francesco Garganese Jun 7 at 8:13
1

disabling the ONLY_FULL_GROUP_BY SQL mode (which it is by default in MySQL 5.7) with this command

mysql > SET GLOBAL sql_mode=(SELECT REPLACE(@@sql_mode,'ONLY_FULL_GROUP_BY',''));

solve the problem about the paging, but it must be considered a workaround.

  • This is no longer necessary upgrading to CiviCRM 5.15.0. The paging problem is solved. – Francesco Garganese Jul 6 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.