2

We are running Wordpress 5.2.1 with CiviCRM 5.12.4. In trying to upgrade to 5.13.5, the database runs through the updates, but then we get the message: "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions." Afterwards, the bottom of the page says "Powered by CiviCRM 5.13.5", but under System Status we get the warning "CiviCRM 5.12 has reached its end of life." indicating the upgrade process didn't run through to the end. Looking at the error_log, there is a fatal PHP error and stack trace which looks like" "PHP Fatal error: Uncaught Error: Class 'CRM_Sparkpost' not found in /home/britstatt/test.sdcbcdream.org/wp-content/uploads/civicrm/ext/com.cividesk.email.sparkpost/settings/Sparkpost.setting.php:8, referer: https://test.sdcbcdream.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fupgrade%2Fqueue%2Frunner&reset=1&qrid=CRM_Upgrade"

We have been using the Sparkpost mail extension since summer of 2016 and have never experienced an issue during the many CiviCRM upgrades since then, so I don't think this is a particular issue with that extension, although I will also ping cividesk. Since the upgrade process has always worked seamlessly, I wanted to throw this out there to find out what might be the matter.

Fwiw, I originally encountered the issue when upgrading from 5.10.3 to 5.13.5, but didn't dive into the error logs. So I ran the upgrade from 5.10.3 to 5.12.4 successfully, thinking doing the upgrade in steps might help. That worked fine, but the subsequent attempt to upgrade 5.12.4 to 5.13.5 generated the error again and I finally looked into the error log.

Our live site is running fine at 5.10.3, but I always run upgrades on a test mirror site, so this is not critical except we really want to move to 5.13.x which is supposed to be the next ESR, I thought.

3

See if https://github.com/cividesk/com.cividesk.email.sparkpost/pull/77 fixes your problem. It's been merged but there has not been a release of the sparkpost extension since then so either pull from git or apply the fix manually - it's only one line of code.

  • Thank you so much @Aidan. That worked and I was hoping it was as simple as an overlooked include in Sparkpost.setting.php. Hope they make this an official update as I can't be the only one to encounter this. – Karl Rudnick Jun 10 at 15:52
  • To confirm for anyone else the above change is now merged. – EagleUK Sep 13 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.