1

I set up a webform with a contribution page. The contribution page has a title, currency, payment processor, contribution amount (£100) and tests fine.

On the webform, it shows as 0.00 and is not loading at all.

Do contribution pages on webforms have to be linked to a membership payment or an event registration?

I'm sure I'm missing something obvious..... enter image description here

enter image description here

4
  • You need to specify whether D7 or D8 I think
    – petednz - fuzion
    Jun 10, 2019 at 19:57
  • It's D7 latest CiviCRM version Jun 12, 2019 at 9:25
  • no they do not need to be linked, it can be pure contribution. perhaps add screenshot from your Components screen
    – petednz - fuzion
    Jun 12, 2019 at 20:16
  • I added a couple of pix Jun 13, 2019 at 11:08

1 Answer 1

1

You’ll need to check off Contribution Amount in your config (on the Webform). Then (in your webform components screen) you can:

  • drag it to where you want to move it to on your form
  • set it to a specific amount and hide it
  • use conditionals to set it to a specific amount
  • with some additional config you can also pass it into the form as a parameter

Webform CiviCRM only takes the config portion (payment processors, thank you and receipting, financial type) bits from CiviCRM Contribution form.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.