0

After installing the extension CiviMobileAPI, I am getting the below error when I access the contacts page. Can you please have a look and support.

Warning: Invalid argument supplied for foreach() in /home/hisadvocate/www/www/wp-content/extensions/com.agiliway.civimobileapi-3.1/com.agiliway.civimobileapi-3.1/CRM/CiviMobileAPI/ApiWrapper/Activity/Get.php on line 31

I am using the Civi CRM version 5.2.1. Any help?

1

I created a PR on the CiviMobileAPI that fixes this problem. See https://github.com/agiliway/com.agiliway.civimobileapi/pull/11

| improve this answer | |
  • Hi Thanks for the update, can you please advise how I can install this fix to my CiviCRM? I am not a programmer, just knows to setup wordpress and install the plugins/extensions – R John Jun 11 '19 at 16:27
  • There are two options. Let me describe the first. The extension shows a warning. That is not an error. A warning is a signal to the programmer that the code must be improved, but the code still works. You can disable the warning. I asked Google for advice and found the following link greengeeks.com/tutorials/article/… . – Kainuk - CiviCooP Jun 12 '19 at 12:11
  • The other option is to overwrite the file with the patch on the filesystem. The file can be downloaded here raw.githubusercontent.com/agiliway/com.agiliway.civimobileapi/… . – Kainuk - CiviCooP Jun 12 '19 at 12:13
  • Thank you, I have copied this file and the warning disappeared! – R John Jun 14 '19 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.