0

CiviCRM 5.14.0 I am using the Sparkpost extension This is a new site in testing phase

I have set my from email address to be: "Site Administrator" This domain has been verified by Sparkpost and is a working mailbox.

If I set up a mailing and click on Track Replies in the response tab, I get this message:

The "Track Replies" option conflicts with the "Reply-To" option. The "Reply-To" option has been disabled.

I assume that this is just a warning that the system will not use the "From" email address for the reply.

When the recipient clicks reply in the email client, the reply address looks like this:

r.105.160.ac5032573de28c3c@vietfeir.com

This address obviously does not exist on in my Postfix virtual_users table. I also believe it should be r.105.160.ac5032573de28c3c@ccrmmail.vietfeir.com and use the domain of the From address.

I changed the reply address to r.105.160.ac5032573de28c3c@ccrmmail.vietfeir.com and got this error.

An error occurred while sending mail. The mail server responded:  
5.1.1 <r.105.160.ac5032573de28c3c@ccrmmail.vietfeir.com>: Recipient address rejected: User unknown in virtual mailbox table.
 Please check the message recipient "r.105.160.ac5032573de28c3c@ccrmmail.vietfeir.com" and try again.

Now, ccrmmail.vietfeir.com is a CNAME that points to sparkpostmail.com but it is still being rejected by my Postfix server.

I'm not sure what to do to fix this.

2

I changed the address to include a local part so VERP. This now works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.