0

After executing a search that returns more than one page of data, I get an error when I click on "next". "Unable to reach the server. Please refresh this page in your browser and try again."

The Apache2 error log shows:

apache2/error.log shows [Mon Jul 08 12:58:29.922448 2019] [php7:warn] [pid 4022] [client 96.9.90.28:57008] PHP Warning:  fopen(/var/www/vietfeir.com/public_html/wp-content/uploads/civicrm/ConfigAndLog/CiviCRM.4a976861044aadd15e2c85b9.log): failed to open stream: Permission denied in /var/www/vietfeir.com/public_html/wp-content/plugins/civicrm/civicrm/vendor/pear/log/Log/file.php on line 216, referer: https://ccrmdemo.vietfeir.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fcontact%2Fsearch&_qf_Basic_display=true&qfKey=082061e63d30f54afa566bb

All of my files have permissions set to 644 and the directories are 755.

All files are owned by www-data:www-data

This is intermittent. I sometimes do not get the error.

8
  • I would check the file owner specifically on /var/www/vietfeir.com/public_html/wp-content/uploads/civicrm/ConfigAndLog/CiviCRM.4a976861044aadd15e2c85b9.log. If you're working on the command line, it's very likely that file was created with a user other than www-data. – Jon G - Megaphone Tech Jul 8 '19 at 14:03
  • All files are owned by www-data:www-data – Vietyank Jul 8 '19 at 17:12
  • I did chown -R www-data: www-data on the site directory. The error message has gone away so that file had the wrong ownership..The network error is still therr – Vietyank Jul 9 '19 at 1:03
  • now that the permissions issue is resolved, does that log file, or other more recent log files, have any recent entries that might help diagnose the issue? – ericG Jul 9 '19 at 4:48
  • Not the Apache log. Does CiviCRM have a log I should be looking in? – Vietyank Jul 9 '19 at 7:30
1

Eileen McNaughton wrote:

It's possible you have FULL_GROUP_BY mode enabled in mysql & that is causing problems - the log file should be /var/www/vietfeir.com/public_html/wp-content/uploads/civicrm/ConfigAndLog/CiviCRM.4a976861044aadd15e2c85b9.log (or similar) and have more error details – eileen 16 hours ago

I removed the ONLY_FULL_GROUP_BY mode and the problem was solved. Thanks, Eileen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.