2

WordPress 4.9.10
CiviCRM 4.7.29

When I'm logged into CiviCRM as an admin, the process of reserving respondents for a survey works fine. However, if I'm logged in with a WP "Contributor" role (which is the role all my civicrm users have) I get an error message when I try to reserve them, "Missing Interviewer contact.", as seen below.

When signed in as a "Contributor"

Looking at the search criteria I see that there is no field to assign the interviewer as there is when I'm logged in as an admin:

when signed in as an admin

I checked my survey-related permissions and I think I have it setup correctly so a person with the "contributor" role should be able to do this:

enter image description here enter image description here

Is there something else permissions-related that I need to be setting, or is this maybe a bug?

Thanks for any help,

Ruth

1

I believe you also need the "CiviCRM: access contact reference field" permission, based on what you're reporting.

  • Thanks for the suggestion. Just checked that and yes, I already have that checked on. – Ruth D Jul 18 at 0:18
1

It seems like you'd need to do 'Administer CiviCampaign' to get it going. What I did was enable that for the user group and then hid the admin stuff from the contributor role for editing the navigational menu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.