1

Attempting to get the Vanco Payment Processor working with Drupal 7.37 & CiviCRM 4.4.15.

Currently it reports a Fatal error: require_once() [function.require]: Failed opening required 'CRM/Contribute/DAO/ContributionType.php'(include_path='/home/honduras/www/www/sites/default/files/civicrm/custom/php/:.:/home/honduras/www/www/sites/all/modules/civicrm:/home/honduras/www/www/sites/all/modules/civicrm/packages:.:/usr/local/php53/lib/php') in /home/honduras/www/www/sites/default/files/civicrm/custom/php/CRM/Contribute/BAO/Contribution/Utils.php on line 66

As a new user/developer working with CiviCRM I am unaware of the changes that occurred between version CiviCRM 4.1.x and CiviCRM 4.4.15.

Can someone shed light on the file ContributionType.php?

1

To answer your exact question - in CiviCRM 4.3+ ContributionType became FinancialType. You might be able to just change the file name.

That said, Xavier is correct - there's likely a newer version of the payment processor. You might want to ask J.C. Grogan. Xavier is also correct that in Civi 4.4+ this code is probably supplanted because of pseudoconstant lookups.

  • I will make the changes you suggest and post an update. – mike_kc Jun 10 '15 at 18:37
  • J.C. Grogan no longer works for Vanco, but he did direct me to the support team. I made an inquiry concerning an updated Payment Processor, but have not gotten a response. The current Vanco Payment Processor is two years old. – mike_kc Jun 10 '15 at 18:50
0

the DAO files are automatically generated based on the database schema. I'm assuming that the goal of including this file is to fetch the list of contribution types. In that case, you should modify the code and use civicrm_api3() to get it, it takes care of knowing where to fetch it.

Lastly, you shouldn't need these includes anymore, they are mostly done automatically based on the class name now.

I'm not familiar with vanco, but you should check if there isn't a newer version of the payment provider extension, you might have quite a few changes since 4.1

  • I have checked with Vanco, they sent me to Back Office Thinking who wrote the Drupal/CiviCRM/Vanco module. Sadly, 4.1 is the last release and they thought it might work with 4.4.x, but not beyond. – mike_kc Jun 10 '15 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.