I am missing the CiviCRM menu bar. I looked into the resource url (should that end in wp-content/plugins/civicrm/civicrm or .org.au/ ?, and should it be https or http if i have ssl certification?).

I've installed the CiviCRM Admin Utilities plugin and this kind of overcomes the issue. But i would like to get the menu to work. It seems more intuitive. I for example can't find a way to add a new organisation with the CiviCRM Admin Utilities alternative.

I'm running 5.5.2 wordpress and 5.15.1 civicrm

thank you for your help, JD


4 Answers 4


Did you Cleanup Caches and Update Paths? It worked for me. Get to it from here: wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2FupdateConfigBackend&reset=1

  • I upgraded three sites from v5.50.3 to v5.51.1 (on WordPress v6.01) and the top menu bar disappeared on all of them. Using the link above, I did the clear cache and then reset paths and the menu bars came back.
    – jsherk
    Jul 27 at 17:23

Make sure that the CIVICRM_UF_BASEURL is set correctly in /var/www/yoursite/sites/default/civicrm.settings.php (or whatever the path is to yout site) I have cloned sites to use for dev and forgotten to change this. It can cause all sorts of issues including a loss of the CiviCRM navigation header.

if (!defined('CIVICRM_UF_BASEURL')) { define( 'CIVICRM_UF_BASEURL' , 'http://yourCiviSite.org/'); }


I don't really have an answer but somehow the same problem, although I think my problem is connected to Drupal as host.

If you do have the same issue, then your menu bar should be on the right place, if you enable Asset Caching at Administer > System Settings > Debugging and Error Handling.

With enabled Asset Caching your image upload url must be configured properly, to make this work. But I am sorry I don't know the right configuration for this in Wordpress.


Have you tried installing uk.squiffle.kam Plugin?

https://github.com/aydun/uk.squiffle.kam you can reach from.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.