Version 5.15.1, on WordPress 5.2.2.

Transferred our site to a new host, and everything seems to be OK -- I can search contacts, navigate various system settings, etc. But the main navigation menu is gone. I've double-checked that it should be replacing the WP menu at the top, and I have run 'Cleanup Caches' and 'Reset Paths.' I've also installed the CiviCRM Admin Utilities plugin and reset the menu with this, no no avail.

'Reset Paths,' however, gives me the following feedback -- is this a clue?

Beginning site move process... WARNING: The setting (userFrameworkResourceURL) is overridden and could not be reverted. Template cache and upload directory have been cleared. Database cache tables cleared. Session has been reset.

As far as I can tell, the userFrameworkResourceURL is correct anyway. Where else should I be looking?

  • Any console erors? Jul 28, 2019 at 8:38
  • When I enable debugging, the navigation menu appears! But I don't see anything alarming there (using the 'SmartyDebug' pop-up, everything is green).
    – mc_burger
    Jul 29, 2019 at 1:28
  • Actually, just realized: with debugging OFF, I also have a bunch of extra page happening below the main pages, like it repeats the whole admin page a couple of times. With debugging ON, that disappears AND the navigation menu appears (and works) as normal. Running with debugging on seems to be the fix, ironically.
    – mc_burger
    Jul 30, 2019 at 5:28
  • What's the harm of running with debugging on? I mean, it's the only way I'm getting everything to work.
    – mc_burger
    Aug 1, 2019 at 6:18
  • OK, one more try. A fresh search today led me to a closely-related problem (civicrm.stackexchange.com/questions/29362/…). According to that, the "files directory is incorrectly configured or inaccessible due to permission problems." I've double-checked that the path is correct, and the directories are all set to 755, with files set to 644. But apparently they're not readable. Any help with this?
    – mc_burger
    Aug 6, 2019 at 9:25


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.