2

CiviCRM 5.15.1, WordPress 5.2.2

My org has been successfully sending bulk SMS via Civi/Twilio for a couple weeks, however we are having problems setting up inbound capability.

The Long Number we lease from Twilio is configured as shown below, with a callback URL as follows: https://www.mydomain.org/?page=CiviCRM&q=civicrm%2Fsms%2Fcallback&provider=org.civicrm.sms.twilio

Twilio config screenshot

The problem is when an SMS recipient replies to a text sent from Civi, Twilio reports error 12200 - Schema validation warning ("provided XML does not conform to the Twilio Markup XML schema"). I understand it's not a fatal error, but I can't find the reply when I look under the senders' Activities. (Anywhere else in Civi I should look?)

Per @balleyne (WordPress Twilio Inbound SMS Callback URL failing when request method is POST), I changed POST to GET and re-tested but got a fatal error instead of balleyne's partial success.

Like balleyne and @CDS-Delano (in a comment to this post: Inbound SMS from Twilio not showing up in CiviCRM (getting 404 error on HTTP POST)), Twilio's debugger console shows that what it gets back from the inbound attempt is html instead of the expected xml (or TwiML?).

Following Chris Burgess's advice in that post, I checked the server and PHP error logs with our hosting provider but saw no red flags around the time the reply SMS was sent.

How have others fixed or at least troubleshot this issue, especially any non-coders (like me) out there?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.