2

WordPress Version: 5.2.2 | CiviCRM - Version 5.15.2 | shared hosting situation with shell access

I've reviewed the various similar questions, but none of them has revealed the answer for me, so I'm posting here. How can I make this error go away? What am I missing?

I click on System Status: Error at the bottom of the UI and get this:

Incorrect Resource URL The Resource URL is not set correctly. Please set the CiviCRM Resource URL.

So I go to the link to set the CiviCRM Resource URL and see this:

URL Variables:

[cms.root] https://mysite.org/

[civicrm.root] https://mysite.org/wp-content/plugins/civicrm/civicrm/

[civicrm.files] https://mysite.org/wp-content/plugins/files/civicrm/

These variables are computed automatically using civicrm.settings.php and its options, such as CIVICRM_TEMPLATE_COMPILEDIR.

CiviCRM Resource URL [civicrm.root]/

Image Upload URL [civicrm.files]/persist/contribute/

Custom CSS URL blank

Disable CiviCRM css Yes x No

Extension Resource URL [civicrm.files]/ext/

Force Secure URLs (SSL) x Yes No

Verify SSL Certs x Yes No

Settings in civicrm.settings.php seem to be correct.

$civicrm_root = '/home/myuser/mysite.org/wp-content/plugins/civicrm/civicrm/';
define( 'CIVICRM_UF_BASEURL'      , 'http://mysite.org/' );
  • 1
    Is anything broken? This could be a false positive. Check the Network tab in your Developer Tools in your web browser, look for anything that doesn't come back "OK", particularly CSS and JavaScript files. – Jon G - Megaphone Tech Aug 1 '19 at 22:38
  • 1
    I wrote this particular check, and it's caused a lot of false positives, so I feel a responsibility to reply to folks who are getting them (and ideally eliminate the problem). Based on your error message, I'm wondering if the System Status page is loading? You can compare it to the one here: dmaster.demo.civicrm.org/civicrm/a/#/status. If not, this isn't a false positive. If it is, I'll try to investigate what could cause that error. – Jon G - Megaphone Tech Aug 5 '19 at 14:29
  • 1
    If nothing is broken, it's fine to just click "Never show me this again". If at some point you stumble across the reason it's happening, please reply here - I really want to squeeze out the false positives! – Jon G - Megaphone Tech Aug 7 '19 at 2:58
  • 1
    Same for me (also older CiviCRM 5.14.2). At some point in time the error occured without any noticable malfunction or network Status error.. @JonG-MegaphoneTech, does ist make sense to describe, what this check tests in particular? – Weidenrinde Jan 27 at 21:44
  • 1
    @Weidenrinde That's an excellent idea. Some of us were discussing ensuring that every error on the status page have a dedicated page in the documentation with additional info; maybe this page should be the test case. – Jon G - Megaphone Tech Jan 28 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.