1

This question already has an answer here:

When I try to enable CiviCase I get a white screen of death and the following msg:

"A fatal error was triggered: Could not create the MySQL views for CiviCase. Your mysql user needs to have the 'CREATE VIEW' permission"

I cannot find any way to add this permission in PhpAdmin. What should I do?

marked as duplicate by Jon G - Megaphone Tech, Community Aug 8 at 17:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • According to my Control Panel, the MySQL user for the database already has 'CREATE VIEW' permission. – Andrew Himes Aug 5 at 21:09
  • Oh just saw this. Is it user@localhost - the part after the @ might be significant and needs to match. Also try running a simple test Create View command manually in phpmyadmin and see what error you get. – Demerit Aug 5 at 21:11
  • See also civicrm.stackexchange.com/questions/20369/… where the problem was a mismatched user domain. – Demerit Aug 5 at 21:17
3

RESOLVED thanks to help from Hershel: Unable to enable CiviCase - Definer v Invoker problem maybe

The solution was to enable remote connections for the specific MySQL database.

0

You'll need to look in your hosting control panel or ask your hosting provider. The mysql user account may not be allowed to have this permission in your hosting setup.

Not the answer you're looking for? Browse other questions tagged or ask your own question.