I have tried following the Roundearth instructions twice to get CiviCRM up and running on a clean install of Drupal 8, on Ubuntu server 18.0.4. First time through, the installer failed with a permissions error but CiviCRM reported as installed—if there's a way of reverting from this situation, I couldn't figure it out, and I ended up having to start over.

Second time through, it all looked good, but going to any CiviCRM page came up blank. Checking PHP errors, it was maxing out memory. So I increased it to 256, 512, and unlimited—each time, it maxed out on memory (3.2 gigs in the case of unlimited, whereas the server has 4), and I gave up and went home. Only to discover when I got there that the pages now loaded, and continued to load with sane memory restrictions. (???) However, there's no CiviCRM menu (it appears to be there, but empty), and when I go to handpasted admin URLs, things that are supposed to be there according to the docs are blank.

Both of these were with the Roundearth instructions—I found a different set here that I'm trying out, but I don't feel good about it.

I have to deploy a staged site by Friday, and if I can't get CiviCRM to work, I'll plow on without it—but I gather that it really wants to be installed before I start piling on other modules. Any help greatly appreciated.

EDIT: Occurs to me that I have not tried installing Drupal from apt-get (if it's there), because the Roundearth composer script had it included. Could try that next before moving on to the linked instructions. Or not, as apparently it's not in apt.

  • Have you seen the resources at this link: lab.civicrm.org/dev/drupal/wikis/drupal8-composer. I'm not sure about the memory problem but the error log will have a line and file where it's happening and that can give a clue. For the blank admin pages maybe start by checking the javascript console for errors and also check your CIVICRM_UF_BASEURL setting in civicrm.settings.php.
    – Demerit
    Commented Aug 10, 2019 at 23:16
  • No, that's all new to me! I'm not sure how to proceed with that page, as there are three different links to HOWTOs, all of them saying "yeah, we need to fix this." I followed the instructions in the first link. Do you suggest I try to hack a solution into the Roundearth install, or try one of the other installation procedures? Commented Aug 11, 2019 at 2:07
  • And thank you! —Jeff Commented Aug 11, 2019 at 2:08
  • It sounds like you almost got the roundearth one going, and except for the weird memory issues seems like it might just be a matter of having the right settings in civicrm.settings.php and elsewhere which might need manual tweaking after. Your best resource for that is probably the second link (hq.megaphonetech.com/projects/commons/wiki/…), and just looking in civicrm.settings.php itself.
    – Demerit
    Commented Aug 11, 2019 at 3:36
  • Well, you're definitely right that my CIVICRM_UF_BASEURL is borked. In the JavaScript console, there are a thousand errors of the form 404 mydomain.org//var/www/html/myorg/vendor... What I can't tell is: my site responds to just mydomain.org—so how do I form the BASEURL so it finds the vendor directory? It's at the same level as the web directory. Commented Aug 11, 2019 at 3:40

1 Answer 1


This ended up being a combination of adding the settings listed at https://hq.megaphonetech.com/projects/commons/wiki/CiviCRM_for_Drupal_8_installation_notes to civicrm.settings.php and the file system permissions.

  • And fixing some boneheaded mistakes between keyboard and chair on the part of the question author. Commented Aug 11, 2019 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.