2

I recently updated the civicrm plugin to version 5.16, the latest. I am trying to configure a event so that it can be paid with IDEAL (that is via interpay - mollie). For this I use admin>system>payment means>add to find a screen where I can add a mollie payment (I have to translate the menu options to english here, maybe a little bit different) In the new payment means, I select 'omnipay - mollie', screenshot of adding payment means

I select an account, add the API-keys, and then, when I change 'creditcard' to the first in the select, being 'IDEAL-omnipay-molly', I get an error screen saying:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.
Deze financiële rekening kan geen '' relatie hebben.

Obviously there is something wrong with the selected account, maybe there is no account number configured, but how can I configure that? Have I missed some documentation on this? Any advise is welcome!

thanks in advance, Ruud

  • Do you have any other extensions installed on your site? – Pradeep Nayak Aug 14 at 15:59
  • 1
    When you go to admin - civicontribute - financial accounts and edit the one for Betaalmethode rekening, does it look all blank to you? I'm wondering if there's a bug somewhere since it's blank on the public demo (payment processor account) when I look there. The error seems to say there's no "relationship" for the financial account (github.com/civicrm/civicrm-core/blob/5.16/CRM/Financial/BAO/…). – Demerit Aug 14 at 16:00
  • I've posted lab.civicrm.org/dev/financial/issues/65 which might be related to the problem. Maybe. – Demerit Aug 14 at 19:10
  • I have changed the code with the pushed fix, but with no result. I have enabled civicontribute, and indeed editing the financial account gives me a form with all blank fields.... By the way, the only plugin next to civicrm is 'classical editor' – ruud Aug 15 at 17:54
1

It looks like either 'Asset Account is' account relationship is deleted or disabled. You can check by navigation to CiviCRM >> Administer >> System Settings >> Option Groups. Find for 'Account Relationship' option, click 'edit option' link besides it. Find for 'Asset Account is' if its disabled or deleted.

Solution:

  1. If disabled then enable it using api or through sql.

  2. If deleted then Add a new one with Label and Name as 'Asset Account is'.

Cheers

Pradeep

  • Hi Pradeep, thanks for your replay. Alas, I have looked in the option screen, and the account relationship exists and is enabled. Any idea what it could be? – ruud Aug 15 at 17:17
  • Can you see in civicrm_option_value table if you can find for Asset Account is? – Pradeep Nayak Aug 16 at 18:08
  • SELECT id FROM civicrm_option_value WHERE name ='Asset Account is'; – Pradeep Nayak Aug 16 at 18:08
  • Hi Pradeep. The table contains a record that satisfies the query. The returned id is 442 – ruud Aug 18 at 9:12
  • 1
    Yes, you need to have civi contribute component enabled if you want to take payments. Hence the form threw fatal error when trying to add payment processor. – Pradeep Nayak Aug 18 at 17:37
1

Oops, in clicking around, the message suddenly disappeared. This is what I did:

  • admin > civicontribute > payment methods (probably; the entry after accounts and before accepted creditcards)
  • I edited the molly entry
  • there I filled in the valueless select box with the account

After that, I was able to save the screen that caused the message. I am a bit desoriented about the relation between the various lists, but I can now continue the configuration. Thanks all for helping me into the right direction! Ruud

  • I forgot to mention that one of the most important actions was to enable civicontribute, which was pointed out by Demerit. This can be done via admin>system>component (first option in menu, don't know the english term for sure). This gives a list of enabled and disabled components, in which I had to enable civicontribute. – ruud Aug 16 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.