1

This question already has an answer here:

I installed civicrm on wordpress, and when I want to configure it: I fall on THIS MESSAGE / Thank you for helping me.

philippe

Parse error: syntax error, unexpected ':', expecting '{' in C:\Program Files (x86)\EasyPHP-Devserver-17\eds-www\secret_defense\wp-content\plugins\civicrm\civicrm\vendor\league\csv\src\functions.php on line 33

Ligne 33 : function bom_match(string $str): string { static $list;

    $list = $list ?? (new ReflectionClass(ByteSequence::class))->getConstants();

    foreach ($list as $sequence) {
        if (0 === strpos($str, $sequence)) {
            return $sequence;
        }
    }

    return '';

marked as duplicate by Demerit, William Mortada, Aidan Aug 30 at 8:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

This seems to be the same as upgrade of civicrm fails with parse error. You need to have php 7.x on the server not php 5.x.

  • thank you, and good day. – philippe Aug 18 at 16:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.