I just installed CiviCRM v5.16.2-wordpress on a WordPress site running WP 5.2.2 Everything seems to be working but I do not have any menus on the top bar. I can get to the Administer CiviCRM screen and have tried different menubar positions under Display Preferences, but still nothing. I am sure I have messed up some setting, but am brand new and have no clue. Thanks for any help.

enter image description here

UPDATE 8-22-2019

Jon G. I followed your suggestions.

I cleared the cache and received this message: enter image description here

Still no menus.

Checked the Resource URL setting and it is correct.

Tried a different theme, no luck.

Went to the Developer's Tools in my Firefox browser and saw mostly 200s and one 404. Here is a screenshot of that 404 error enter image description here

Looking at the error details, I went to the location of the file in my hosting File Manager and the file is there (along with several others) enter image description here

Suggestions for what else I can try? Thanks.

UPDATE: 8-23-2019

Well, I've been trying different things. I went into Debugging from the Adminster CiviCRM screen, turned on debugging and switched to Development mode. When I saved those changes, the menubar appeared. If I switch back to Production mode they disappear.

  • The same thing happened to me with my subdomain sandbox after I upgraded to 5.16.4 from 5.15.1 Commented Sep 3, 2019 at 16:10
  • Is this related at all? civicrm.stackexchange.com/a/31644/26
    – Laryn
    Commented Sep 3, 2019 at 18:36
  • @GeorgeLozier, thanks for letting me know.
    – jeff_in_ky
    Commented Sep 4, 2019 at 17:55
  • @Laryn-CEDC.org not sure. The issue is not a big enough concern for me to take too much time to delve into it, but thanks for the input.
    – jeff_in_ky
    Commented Sep 4, 2019 at 17:57
  • I have been having the same issue for months now. I thought it must be a known bug but was surprised it was not fixed on subsequent Civicrm releases. This issue is there for all my new sites. I just did a clean new installation with latest WP and latest Civicrm and still the same. Additionally for contribution pages Live links (eg : myURL/… returns the default Civicrm Page. I have to use short codes for everything. I am on a IIS 6.2 server with PHP 7.3.7. The bigger problem is none of the forms are submitting data as wel
    – sri
    Commented Sep 23, 2019 at 10:48

3 Answers 3


I would try clearing caches (click Cleanup Caches and Update Paths on the admin menu). I would also check your Resource URL to make sure it's correct (click Resource URLs on the admin menu).

I would also try using one of the built-in themes (e.g. "twentynineteen") to rule out a badly-behaving theme.

Finally, I would try bringing up your browser's Developer Tools (press "F12"), heading to the Network tab, and reloading the page. If you see any 404, 403, 500 errors - really, anything besides a 200 - please update your question with those details. Also note that you'll want to do a hard refresh of the page in between the first two steps - that's Ctrl-Shift-R on Windows/Linux, and Cmd-Shift-R on a Mac.

UPDATE: Looking at the request URL in your screenshot, that looks pretty squirelly. I very much doubt thaat's the correct URL. That says to me that there's probably something wrong with your Resource URL. Is it possible that you're using a symlink ("alias") in your file path? If so, try to fix any paths defined either in Administer » System Settings » Directories or in civicrm.settings.php to use the equivalent non-symlinked path.

  • Jon G. - Thanks for responding. I edited my question with what I found.
    – jeff_in_ky
    Commented Aug 22, 2019 at 19:29
  • @jeff_in_ky I updated my answer, let me know if it helps. Commented Aug 27, 2019 at 0:01
  • 1
    Thanks, Jon G. That makes sense. I've concluded that it has something to do with file paths. I'll play around with it when I get a chance and see if I can nail it down. Thanks again for your help.
    – jeff_in_ky
    Commented Aug 28, 2019 at 17:55

OK, I am not sure what is actually causing the problem, but I believe it is related to file and resource paths. The site that I installed CiviCRM on is a subdomain. I use that site as a Sandbox to test things before going to the main site. I installed CiviCRM on the main WP site at our domain and the menus appear fine. On the Sandbox site, since I can put the site into Development mode and the menus appear, I am not going to spend anymore time on getting to the root of the issue.

Thanks for the suggestions.


I 'fixed' this on my sandbox WordPress installation by:

  1. Uninstalling CiviCRM.
  2. Doing a fresh install of the latest CiviCRM version.
  3. Installing my extensions.
  4. Restoring a copy of my production database.
  5. Upgrading the database.
  6. Clearing the Caches and rebuilding the menus.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.