2

CiviCRM 4.7.31 WordPress 5.2.2

I get this error in the log file but don't have any geocoding provider selected (nor wanted) in Settings -> Mapping and Geocoding Providers. I think this is happening when new contacts are entered. It does not stop the contact from being entered successfully.

Any ideas what to change to stop this error (short of adding a geocoding provider, do not want that).

Message: Aug 28 10:03:44 [error] Configured geocoder is invalid, must provide a format method Array ( [geocode_class] => )

2

You probably had it set to yahoo at some point, and then when yahoo was removed somehow the setting didn't get blanked out, so it's looking for the yahoo code files but they aren't there anymore. Did you try just re-saving the page at Mapping and Geocoding Providers with none selected? That should clear it.

  • Ah that makes sens! – KarinG - Semper IT Aug 28 at 23:41
  • I re-saved the page and haven't had the problem since then. Thanks! – Michele Rizack Sep 11 at 23:21
  • Sadly the problem has reoccured so the resaving with none selected did not fix the message. – Michele Rizack Sep 13 at 21:43
  • Do you have any extensions that implement geocoderFormat? Do a grep -r geocoderFormat * in your extensions directory. – Demerit Sep 13 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.