1

In Civicrm 5.4 and in current version in WP Sandbox, it seems that the 'Developer' tab is no longer shown. What is the replacement/suggested method for adding a column to reports now?

2

To view developer tab for the report the user will need 'CiviReport: view report sql' permission. This is new permission added in recent version of CiviCRM for broader access control.

You can set permission by navigating to CiviCRM >> Administer >> Users and Permissions >> Permissions (Access Control) >> WordPress Access Control

HTH

Pradeep

  • This user is an Administrator (this is a WP site). Don't administrators by default have all perms? How do I set/select this permission, in current ACL settings this isn't clear to me.Thanks. – Lesley Evensen Sep 5 at 16:24
  • I am an administrator and I am not seeing developer tab; in the WP sandbox (wpmaster.demo.civicrm.org) when I login as admin, I also don't see developer tabs in reports. – Lesley Evensen Sep 5 at 16:36
  • The demo user on the wordpress sandbox does not actually have all admin permissions. In your own wordpress if you are a higher level admin you will see these settings at example.org/wp-admin/… – Demerit Sep 5 at 18:21
  • You need to add permission for each role. The demo user don't have above permission hence you were not able to see the developer tab. I have updated my answer on how you can set permission – Pradeep Nayak Sep 5 at 19:21
  • In this case, I am an Administrator, and while Wordpress Access Control section lists all particular permission for the roles for Author, Contributor, etc., the text does say that Admins have all perms ("NOTE: Super Admin and Administrator roles will have all permissions in CiviCRM.") and doesn't list Administrator at all for specific permissions. thanks anyway. – Lesley Evensen Sep 5 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.