1

I am running on the latest version of CiviCRM, 5.17, and when I go into CiviMail to create an email message the HTML wysiwyg editor does not load. I get a console error saying CRM.wysiwyg._create is not a function

If I put a debugger right before the line I can see the the CRM.wysiwyg object does not have ._create method but it does have a .create() method. If I change the code to use the .create() method then it seems to loop for ever and the tab stops responding.

I had this issue on the previous version of civicrm, 5.13, which is why I tried the upgrade to 5.17.

There is a message during upgrade about updating the templates but when I click the link for more info it take me to a page saying the documents have moved.

I do have the ckEditor enabled on the site.

I am running on wordpress 5.0.4.
I did reset the cache and clear the templates_c folder but neither cured it.
Any suggestions would be appreciated.

  • Have you cleared the cache? Tried in another browser? Ad-blocker enabled? – Zachary Sep 7 at 5:16
  • Can you check resource url? – Pradeep Nayak Sep 7 at 7:41
  • I did clear the cache and the templates_c folder. I have tried on multiple browser and is always the same error. I dont have an ad-blocker enabled. – civi5 Sep 7 at 14:31
  • As for the resource urls they are all set. I dont see any other errors in the web console. It seems the API for wysiwyg is not the same for some reason. Any suggestions on where to look for ideas? – civi5 Sep 7 at 14:37
  • I have made some more progress on this issue. I found that my theme was redirecting 404s to the login page. Once I disabled that then I was able to find that I am getting a 404 loading crm.ckeditor. I found the reference in Core/resources.php It seems the file is looking to be loaded from "[civicrm.root]/js/wysiwyg/crm.ckeditor.js. In my settings file I have civicrm_root pointing to the base directory in /var/www.... So it tries to load that file as the URL with the /var/www in the URL. If I hard code that reference to the file location it works. Is there a relative var I can use – civi5 Sep 7 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.