4.6.3 with Joomla 3.4.1 and PHP 5.4.4, When clicking Mailings -> New Mailing, I get a blank page with frozen CiciCRM menus and a single link back to the CiviCRM home page.

New mailing was working prior to upgrading both CiviCRM (from 4.1 ) and Joomla from 2.5. All other parts of CiviCRM are working.

I tried the Troubleshooting guide including disabling extensions but nothing works. Any ideas?

javaScript errors appear:

Uncaught SyntaxError: Unexpected identifier ?option=com_civicrm&task=civicrm/ajax/l10n-js/en_US&r=TKdmc:5 Uncaught TypeError: Cannot set property 'userFramework' of undefined(anonymous function) @ ?option=com_civicrm&task=civicrm/ajax/l10n-js/en_US&r=TKdmc:5(anonymous function) @ ?option=com_civicrm&task=civicrm/ajax/l10n-js/en_US&r=TKdmc:76 crmApp.js?r=TKdmc:5 Uncaught TypeError: Cannot read property 'modules' of undefined(anonymous function) @ crmApp.js?r=TKdmc:5(anonymous function) @ crmApp.js?r=TKdmc:13 ?option=com_civicrm&task=civicrm/ajax/menujs/2/en_US/1/sG2nikkH:110 Uncaught TypeError: Cannot read property 'resourceBase' of undefined(anonymous function) @ ?option=com_civicrm&task=civicrm/ajax/menujs/2/en_US/1/sG2nikkH:110(anonymous function) @ ?option=com_civicrm&task=civicrm/ajax/menujs/2/en_US/1/sG2nikkH:111 angular.js?r=TKdmc:63 Uncaught Error: [$injector:modulerr] Failed to instantiate module crmApp due to: Error: [$injector:nomod] Module 'crmApp' is not available! You either misspelled the module name or forgot to load it. If registering a module ensure that you specify the dependencies as the second argument. http://errors.angularjs.org/1.3.15/$injector/nomod?p0=crmApp at REGEX_STRING_REGEXP (


2 Answers 2


RESOLVED: Answer is in Problem with CiviMail Menu on Joomla 3.4.1 - CiviCRM 4.6.2

Add to civicrm.settings.php define('CIVICRM_CIVIMAIL_UI_LEGACY', 1);

That fixed it for now as this apparently won't be an option in 4.7


For those that are still encountering this, the problem seems to be the combination of CiviCRM 4.6 and Joomla 3.4.1. If you upgrade to Joomla 3.4.3 though the problem is resolved without having to add the line above to your settings file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.