1

A recent security update from our host has resulted in cron throwing out the following errors:

PHP Warning: ini_set() has been disabled for security reasons in /.../public_html/wp-content/plugins/civicrm/civicrm/vendor/symfony/config/ResourceCheckerConfigCache.php on line 84 PHP Warning: ini_set() has been disabled for security reasons in /.../public_html/wp-content/plugins/civicrm/civicrm/vendor/symfony/config/ResourceCheckerConfigCache.php on line 99 PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2359296 bytes) in /.../wp-content/plugins/classic-editor/classic-editor.php on line 631

We have been asked to find a workaround rather than reducing security on the server. I've searched around and not found any posts with similar issues so I'm not sure where to start. Any direction would be appreciated.

2

Can you ask your host about raising php's memory_limit setting to at least 128MB. 32MB is below the current recommended minimum for CiviCRM of 256MB (see https://docs.civicrm.org/sysadmin/en/latest/requirements/#php-configuration), and the absolute minimum value used in the configuration file that calls ini_set() is currently 128MB (see https://github.com/civicrm/civicrm-core/blob/5.17.0/templates/CRM/common/civicrm.settings.php.template#L540)

  • thank you. that did it! – gchinola Sep 10 at 0:28
  • Great! . . . . . – Demerit Sep 10 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.