3

I am working a new extension that i created throough civix. i have added some pages and some forms, how do i display the menu on the home page of the extension and navigate to the different pages and forms. when i install my extension and run it, i get this message: Thank you for creating with WordPress.

Version 4.2.2

  • Are you really using CiviCRM version 4.2.2? That's super old, unsupported, and insecure, and I'm not surprised it doesn't work. – Coleman Jun 16 '15 at 2:15
  • No, thats the version of wordpress not Civi, my civi is the latest version! – Aka Rolence Jun 17 '15 at 3:26
  • Please edit your question to say exactly what command you typed to generate the pages/forms. – Coleman Jun 17 '15 at 13:06
  • civix generate:page Facebooksettings/facebooksettings for example – Aka Rolence Jun 30 '15 at 13:07
  • Pls edit your question to add details rather than commenting. Looks like you typed a path that doesn't start with civicrm? I don't think that's supported. – Coleman Jun 30 '15 at 13:28
4

Whenever you modify a menu xml file you must clear CiviCRM's menu cache.

Go to Administer > System Settings > Cleanup Caches & Update Paths and click the Cleanup Caches button.

  • great, I have done that but I stiil get the same information, its like my menu xml file is not been read or may be am not doing it correctly. But I just want to access a basic page i created after creating the extension.This should not be so difficult and hidden I think. – Aka Rolence Jun 15 '15 at 11:47
  • Normally it isn't difficult. If you use the "civix generate:page" command and clear your cache, it will become available immediately. Note the web path should always start with "civicrm". – Coleman Jun 17 '15 at 13:05
  • Thanks @Coleman for the tips i succeded with this problem. – Aka Rolence Jul 1 '15 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.