2

I’m trying to install a new copy of CiviCRM for Wordpress on Plesk Onyx. I get the following error when I try to activate CiviCRM after uploading the files to my server:

Warning: require_once(CRM/Core/ClassLoader.php): failed to open stream: No such file or directory in /var/www/vhosts/ruinsideca.org/infoportal.ruinsideca.org/wp-content/plugins/civicrm/civicrm.php on line 877

Fatal error: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/opt/plesk/php/7.2/share/pear') in /var/www/vhosts/ruinsideca.org/infoportal.ruinsideca.org/wp-content/plugins/civicrm/civicrm.php on line 877

I don’t know why this error is happening or how to fix it. I’ve never come across something like this before. As a result, I can't even install CiviCRM on my server.

I'm running PHP 7.2.22, Wordpress 5.2.3, and CiviCRM 5.17.3.

Thanks for your help

7
  • Just to make sure, is there a file at /var/www/vhosts/ruinsideca.org/infoportal.ruinsideca.org/wp-content/plugins/civicrm/CRM/Core/ClassLoader.php? Maybe something didn't get fully uploaded. Or maybe the file owner/permissions are wrong?
    – Demerit
    Sep 12, 2019 at 5:56
  • The file exists. I set the permissions to allow everything on that file. It's still not working.
    – com1tech
    Sep 12, 2019 at 19:12
  • @com1tech I suspect the permissions are the problem. Try making Classloader.php permissions 644.
    – Tommy B
    Sep 12, 2019 at 19:54
  • 1
    Thanks everyone for your suggestions. I found that there was a plugin conflict that was causing the issue. After disabling the plugin, I was able to install CiviCRM.
    – com1tech
    Sep 12, 2019 at 23:01
  • 1
    I encountered this also, it was the plugin "CiviCRM integration for Caldera Forms" which I'd installed before CiviCRM and this caused the problem described above. Jan 22, 2020 at 6:10

2 Answers 2

2

Same happened to me. On installing new test CiviCRM under WordPress. The "CiviCRM Contribution Page Widget" plugin caused same error. Civi 5.27.1, WP 5.4.2, php 7.2.24 on ubuntu 20.04 LTS

1
  • Is this an Answer or just a 'me too'
    – petednz - fuzion
    Jul 26, 2020 at 20:39
0

I encountered similar error messages attempting to activate CiviCRM 5.28.0 (but not on Plesk).

The error in that situation was caused by a previous, failed installation attempt on the site this one had been cloned from. Removing all CiviCRM files and tables then enabled the plugin to be activated correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.