I am trying to move a CIVICRM installation up to the 'last' PHP56 supported release which I believe its 5.13.5 however it triggers the PHP7 check expected from 5.14 onwards?

So after running: drush civicrm-upgrade-db I get:

CiviCRM requires PHP 7.0.0+. Drush is running PHP 5.6.40.

Is this expected on 5.13.5?? Any help appreciated.

No mention of a PHP7 requirement on the patch notes: https://github.com/civicrm/civicrm-core/blob/master/release-notes/5.13.5.md#synopsis

  • Don't know what the last php 5.6 release is, but I'd put the effort into moving to php 7. What stops you upgrading to php 7? – Aidan Sep 13 '19 at 9:13
  • @Aidan It's a large install, I've been aiming to moving up within the next month but this was more of a stop gap. It's just weird how this was completely ommited in the version notes and version v5.14 was meant to be the first version that stopped support. – EagleUK Sep 13 '19 at 10:33

Had to move just to 5.13.4 as that is the last 'supported' version. 5.13.5 doesn't but no information is given to suggest it's incompatible on patch notes.

Will test and move it up from this version :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.