2

Recently moved my CiviCRM install to a server running Debain 10 which brings:

  • php7.3
  • MariaDB 10.3.17

Everything seems to be working fine, except that in the system checks I'm now seeing this error/warning:

PHP MySQL Driver (libmysqlclient)

It is recommended, though not yet required, to upgrade your PHP MySQL driver (libmysqlclient) to >= 5.5.3 for utf8mb4 support.

The check seems to get its info from mysqli_get_client_info which on my server emits the following:

mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23

This is surprising - 5.0?! What to do?

  • This came up in labs a few months ago but was resolved (lab.civicrm.org/dev/core/issues/1136). But I don't have any insight as to what's different here. Is there anything in that ticket that helps? – Demerit Sep 13 at 12:44
2

Thanks to @Dermerit, the answer seems to be to upgrade!

This code change: https://github.com/civicrm/civicrm-core/pull/14864/files

Seems to have removed the erroneous warning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.