I have downloaded, then uploaded civix.phar to my www/www directory (where Drupal is installed).

Now, if I run civix civicrm:ping (from this www/www directory), the answer is :

-bash civix: command not found

(I also tried civix.phar civicrm:ping : I get the same answer) (I also tried from other directories : I get the same answer)

I am not a linux expert ; what am I missing ? (permission is 775)

2 Answers 2


Use either php civix.phar or ./civix.phar or first update your PATH:

set PATH=$PATH:/path/to/folder/where/you/downloaded/it

  • When I use php civix.phar or ./civix.phar, I get : "Failed loading /usr/local/ioncube/ioncube_loader_lin_7.1.so: /usr/local/ioncube/ioncube_loader_lin_7.1.so: undefined symbol: zend_interrupt_function" ; Sep 13, 2019 at 16:27
  • try php71 or php72 instead of php. There might be multiple versions installed.
    – Demerit
    Sep 13, 2019 at 16:28
  • Why should I update my PATH, since I run civix from where I downloaded it ? I did however, but no change. Sep 13, 2019 at 16:29
  • Usually your extensions go in files/civicrm/ext so you usually run it from there but setting path is optional.
    – Demerit
    Sep 13, 2019 at 16:32
  • php71 or php 72 do not change anything ; my extensions are in www/www/sites/default/files/civicrm/ext ; should I set the PATH there (while civix.phar is in www/www) ? My current php.ini file is as follows :zend_extension = /usr/local/ioncube/ioncube_loader_lin_7.1.so post_max_size = 20M memory_limit = 500M upload_max_filesize = 20M max_execution_time = 120 expose_php = Off session.save_path = /tmp error_reporting = E_ALL & ~E_STRICT & ~E_NOTICE & ~E_DEPRECATED date.timezone = "Europe/Sofia" Sep 13, 2019 at 17:08

It was a php configuration issue, now solved by my hoster ; I must use php civix.phar command, and it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.